Last Updated: Nov 14, 2024
Overview
My Android app seems to be having trouble. I am logged in on one device just fine using fingerprint via Auth0 biometrics. I have a second device and want to login using the same account. When I get to the point in the flow where I’m asked to “Use fingerprint or face recognition to login…” and I tap Continue, I get this error message:
" No passkeys available. There aren’t any passkeys for auth.online on this device "
What does this error mean, and how can I resolve it? I can use the password used when converting this user to Auth0, and that works, but not the desired user experience of having to use a password when rather use biometrics. Both devices have fingerprint defined at the Android settings level.
Applies To
- Biometrics
- Error
- passkeys
Cause
This error was being returned because the user was attempting to enroll a second device in biometrics and it was the same type of device as the first one that had been enrolled. In this case, the device throwing the error was a Pixel 7, and the other was a Samsung Galaxy Z fold in opened – mode, which was interpreted as a tablet layout type.
Solution
There is a limitation with biometrics where users can only enroll one device per type using WebAuthn with Device Biometrics (one phone, one tablet, one laptop/desktop). If a user wants to enroll another device of the same type, the first device must be unenrolled.