The send-phone-message Action Trigger does not Appear to be Executing

Problem statement

After creating a ‘send-phone-message’ Action, the login attempt fails with the following error:

Failed to send voice message

or

Failed to make MFA voice call

In the ‘Realtime Webtask Logs’ extension, there is no indication that the Action was executed - e.g no errors etc and no console.log statements are printed.

Changing the MFA provider back to ‘Twilio’ fixes this and sms / voice calls are made - but changing it to custom just gives a blank ‘We couldn’t send an SMS / make a voice call’ error.

There is no more info under monitoring → logs, it prints the same generic error message.

Cause

This issue can occur by having a send-phone-message Hook enabled at the same time as the send-phone-message Action. If a send-phone-message Hook is enabled, then a send-phone-message Action will not run. This is true only for this flow.

Additionally, the send-phone-message Action does not run if Twilio is configured as the SMS provider.

Solution

If the send-phone-message Hook is not needed, disable it and use the send-phone-message Action instead.