"The security token included in the request is invalid" error when sending email from AWS SES Email provider

Problem Statement

After configuring SES as the SMTP provider, email delivery is failing and the following error log is shown:

"The security token included in the request is invalid".

Symptoms

When attempting to send an email from Auth0 the error ‘the security token included in the request is invalid’ is shown.

Cause

If the SES credentials appear correct and have not been updated recently by another admin, this may come down to behavior from a Password Manager installed on an admin’s browser.

Password managers may have an option enabled to autofill passwords, and it can mistakenly fill in and update the credentials added to the Auth0 Dashboard Email provider settings when accessing that page.

If this is the case, dashboard tenant logs may have an 'Update the email provider’ log indicating a change has been made to that configuration.

Solution

Disable password manager autofill and auto-submit and re-add the correct credentials as needed.