"Support Access - DEPRECATED" Role Displayed on Management Dashboard

Overview

This article explains why the “Support Access - DEPRECATED” role appears in a tenant member’s assigned roles. This role is visible when navigating to Tenant Settings > Tenant Members, selecting the More Actions menu for a user, and choosing Edit Roles.

Applies To

  • Support Access role
  • Support Access deprecation

Cause

The “Support Access” role was deprecated in August 2024. If not manually removed, the role name will change to “Support Access - DEPRECATED.”

Solution

  • The “Support Access - DEPRECATED” role has no functional effect and will be automatically removed in the future. No action is required to delete it.
  • To grant the intended permissions, assign the new “Elevated Support Access” role to any tenant member who needs to view and manage support cases for other tenant members.