SSO Not Working with SAML


There are two applications in Auth0, and both have the SAML addon enabled.
If the user is going to application A, authenticates, and then navigates to application B and triggers authentication, it gets redirected to/u/login for authentication. The session is not picked-up.


The applications are enabled for different database connections.
For SSO to work, both applications must be enabled for the same connection.


Enable the SAML-addon applications for the same database connection.

  1. Go to Dashboard > Applications.
  2. Click on the Connections tab.
  3. Enable the same database connection for the SAML-addon applications.