SSO doesn't work

I have a few applications but I can’t set up SSO (single sign-on) between those applications. What am I doing wrong? I’ve enabled the seamless SSO on my tenant.

For SSO to work, the following two conditions should be satisfied:

1- The login should happen on the same domain. E.g., if the custom domain is used for one app, the other apps should use the custom domain too. This is required because the user sessions are managed with a session cookie named auth0 set on the login domain.

2- If different apps are using different clients/apps on the Auth0 dashboard, the connection user is authenticating should be enabled for all of these applications on the Auth0 dashboard.

There may be some other edge cases too. E.g., setting up the session inactivity period too short for the seamless SSO, but the above two items are the most common reasons.

I have this exact same problem and nowhere tells you how to actually get this to work. I have two applications, both of which have Auth0 working on them fine, they just don’t recognise that you’ve already logged into the other one and hence can’t give you single sign on. Both are operating from the same Au0 domain. Every time this subject is listed in the community, you’re just given links to an explanation of what SSO is, not how to actually set it up.

Horrendously infuriating, particularly if you’re not a programmer with 20 years experience.

@contact12 In your setup, you’re not satisfying requirement 2 of the solution given above. (See my comment in your other post)

the connection user is authenticating should be enabled for all of these applications on the Auth0 dashboard.

1 Like

Hi, can you please let me know what setting this is? The phrasing of the above doesn’t make any sense to me :slight_smile:

I’m referring to the other thread Single Sign On - Not Working where you said:

Both are under the same tenant and both have their own DB connection.

Which implies that it doesn’t fulfill above mentioned requirement

the connection user is authenticating should be enabled for all of these applications on the Auth0 dashboard.

Yes, its the “the connection user is authenticating should be enabled for all of these applications on the Auth0 dashboard.” part I don’t understand. Is there a word missing between “Connection” and “user”? The sentence does make sense

I guess it should be “the connection against which the user should be authentication should be enabled for all these applications on the Auth0 dashboard.”

I’ll continue the discussion in your other original thread.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.