Auth0 Home Blog Docs

Some quick starts show "authorize app" dialog

quickstart

#1

I have tried four different quick starts: Java, Go, Scala play framework and node.js. I’m able to build and run all of them but they exhibit different behavior when I log in. With Java and node.js I’m shown a “welcome” page after I submit my username password. But with Go and Scala I’m shown an “authorize app” dialog. See screenshot. Why is this?![alt text][1]


#2

[Issue Below SOLVED] . I thought that I had updated the callback url but I had it still set to localhost. When I changed that to myapp.dev it seemed to skip the consent thing.

[This issue below solved, it seems]
I’m trying to prevent the consent thing from being shown as well after the user enters their username/password (it even happens for the node examples for me). I added a scope and that was part of the consent questions as well. Seems to occur even if I map 127.0.0.1 to myapp.dev.


#3

The quickstarts don’t say anything about scopes or changing the hostnames in the callback URLs though.


#4

I have this issue as well and it is not solved, how is anything you said supposed to solve the issue?


#5

@admin13 I was able to solve this. The problem is due to the fact that I was running the quick starts on localhost. The relevant documentation about this issue here: https://auth0.com/docs/api-auth/user-consent

In order to make the “authorize app” dialog go away I had to do four things:

  1. Find a name other than than localhost to use to refer to my own machine. In my case there was already another alias defined in my /etc/hosts file (the link above explains this)
  2. Go to my client’s settings (on manage.auth0.com) and change the “Allowed Callback URLs” and “Allowed Logout URLs” to use the new alias instead of localhost
  3. Find the place in the quickstart code where “localhost” was hardcoded. For example in the Python quickstart this is stored in the “.env” file. Change “localhost” to the new alias.
  4. Access the running app through http://[the new alias]:port instead of http://localhost:port

#6

Great!
Thanks for the clarification


#7