Clarification on skipping consent popup

Previously, I’ve mapped a domain to run my local environment on a domain other than ‘localhost’ (by editing /etc/hosts) in order to avoid the consent popup appearing in our production environments (we use a single tenant).

A recent change in our organisational workflow has meant continuing to use this method might not be possible going forward, and we may be required to go back to developing on the localhost domain.

Recently I’ve added https://localhost:3000 back into our Auth0 application’s list of Allowed Callback URLs, and while the consent popup has appeared on my local environment, it hasn’t yet appeared while testing on production.

Looking at the documenation outlined here:

Similarly, you cannot skip consent (even for first-party applications) if localhost appears in any domain in the application's **Allowed Callback URLs** setting (found in [Dashboard > Applications > Settings](
(User Consent and Third-Party Applications)

It sounds like I SHOULD be seeing this popup again in production too (even though it’s not what I want).

Have I interpreted this documentation incorrectly (ie. the consent popup will show on localhost, but not a production domain)?
Did I interpret it correctly (ie. it just might take some time for the consent popup to reappear in production)?