Ignore consent with custom domain in auth0

We are using custom domain in our auth0’s application. We have enabled the option of “Allow Skipping User Consent”.

When we are adding custom domain in our auth0 variables at client side. It is still asking for user consent on our deployed site.
Interestingly, if we replace that custom domain in our code, with the actual domain of that auth0 application, then it works exactly as expected.

Could it be possible that using custom domain, is considered as a third party application?
Would really appreciate if anyone can help in this. Thanks!

Hi @divyasmehta,

Welcome to the Community!

I have not seen this happen for custom domains before, but I can confirm! Do any of the Allowed Callback URLs of the application contain localhost by chance?

…you cannot skip consent (even for first-party applications) if localhost appears in any domain in the application’s Allowed Callback URLs setting (found in Dashboard > Applications > Settings). Make sure to update Allowed Callback URLs and the callback URL you configured in your application to match the updated domain-mapping.

@stephanie.chamblee Thanks for your response. Yes localhost was the issue. I was able to figure that out later.

1 Like

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.