[Solved] Token retrieval issue, status 500, Invalid URL


I have a few tenants which are working fine, except for one.
This one was working fine for like 2 years now, but starting beginning of August, we are not able to login anymore, I mean, the request to retrieve the token is returning a status code 500 →

HTTP/2 500
{“error”:“ERR_INVALID_URL”,“error_description”:“Invalid URL”}

Looking around, I have seen an incident yesterday, but it should be resolved now: Service Disruptions in the EU-2 Production Environment • Auth0 Status Page
However, I still have the same issue when trying to request a new token on:

POST https://.eu.auth0.com/oauth/token

I checked the Production Readiness, and it seems to work fine for all my tenants, except for this one:

Nothing changed on my side, and I can see users activities in my logs on July 31st, so I know that it’s happening since beginning of August.

I tried to search around the community, but I didn’t find a topic related to this issue.
Did anyone encounter the same issue ?

Any help would be greatly appreciated.


Updating the topic, in case it happens to anyone else.

After talking with Auth0 support, it was caused by a URL inside Allowed Callback URLs, Allowed Logout URLs and Allowed Web Origins., in our Application Settings.

I still don’t know yet if anything has changed on Auth0’s side for the URL to start causing Internal Server Error, maybe a pattern matching for URL validation (the URL had a custom pattern).

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.