Social login not longer working

Hi, I’m getting error 401 for some reason.
I configured Wordpress and Auth0 a few months ago and it was working well but I tried to log in today and I’m getting this error. I haven’t changed anything so I suspected it could be an automatic update from Wordpress but I didn’t have any luck after reverting versions and disabling all plugins.

When I try to log in I get this log which seems to be working, but on the Wordpress logs it mentions that I need a ‘client-grant’ associated with the API

A clue that I found is with the Client IDs
I have a python ID for my application (which I won’t use now) and the Wordpress Client ID

But I can see on the error page that it’s using the wrong Client ID


Would anyone know what’s going on?
I appreciate any help

Hey there @alx.leiva !

Thanks for the detailed description - Honestly not sure what could be going on here :thinking: What is the full url where the incorrect client_id is included?

Hi tyf!

The full url is:

https: //

I just notice that the wrong client id was indeed taken from social connection as shown here.
If I try that “Try connection” it won’t work.

This is a new options from last time I was configuring, could it be related?

Ok I just found what was wrong, I just went through the steps in the Setup Guide shown here and it worked, that’s quite obvious. The strange this is that I did not follow any of this steps before and I know it for a fact because I didn’t even had a Google developer account and anything created on the console. How did it work before?? I have no idea, is this a new requirement?
Who knows, I’m glad it’s working now.

1 Like

Hey @alx.leiva thanks a bunch for following up with the community on this - Good to know it’s working now :slight_smile:

I assume you were just using Auth0 Developer Keys before.


Is it possible that Auth0’s developer keys just stopped working? I’m using Free version for more than 1 month and today it just doesn’t work. I thought it is my fault but… even test button on management portal doesn’t work. Nothing has been changed on my side … :frowning:

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.