Google Social login fails with Unauthorized error


I am trying to set up a Google Social Connection in one of my tenants, but I am receiving this error when I test the connection.

I did the same configuration in another tenant, and it worked.

Does anyone know what could be the problem?

  "date": "2022-04-11T17:44:06.609Z",
  "type": "f",
  "description": "Unauthorized",
  "connection": "google-oauth2",
  "connection_id": "con_bzmiByM4ohw0RF6S",
  "client_id": "1sJO2VDJhev9N9MTxFzMkzhgSlB4dXEK",
  "client_name": "All Applications",
  "ip": "2603:9001:7300:d504:d5aa:f0a0:b803:1ce",
  "user_agent": "Chrome 100.0.4896 / Mac OS X 10.15.7",
  "details": {
    "body": {},
    "qs": {
      "state": "pefSTSRlDEJP6i1ySaCW-FszwcAv_ziL",
      "code": "4/0AX4XfWjrZFvwtFzbDC5HhUf9TGW2WpFZH8C_Y-kFX6de6E9SYWTYCEe9jHzEAJ8qYd0JKw",
      "scope": "email profile openid",
      "authuser": "0",
      "hd": "",
      "prompt": "none"
    "connection": "google-oauth2",
    "error": {
      "message": "Unauthorized",
      "oauthError": "invalid_request",
      "type": "request-error"
    "session_id": "fIICphhw7GcU4g37G3cT6MZBCGh6SblB"
  "hostname": "",
  "strategy": "google-oauth2",
  "strategy_type": "social",
  "log_id": "90020220411174408200922427356414379403130822526970626050",
  "_id": "90020220411174408200922427356414379403130822526970626050",
  "isMobile": false

Hi @andre3 ,

Welcome to the Auth0 Community!

I checked the google-auth02 connection under your demo tenant and noticed that the “All Application” application is disabled. Did you disable it because of the error?

Could you please try logging into another application under the same tenant using Google Social login and let me know if it’s the same error?

BTW, did you use the same Google credential to log into both tenants?

1 Like