Sending verification mails manually?!

Tried to send email verification mails by myself. After disabling “status” under emails>templates>verification mail I’m no longer able to send the verification mail manually by using endpoint “api/v2/jobs/verification-email”. It returns status: “pending”. Job never changes to complete. What am I doing wrong?

Verification emails won’t be sent if the status is disabled. How are you creating your users? Are they signing up via Lock, or are you creating them manually via API v2?

creating them manually via api v2 … found this in the docs:

You could call the post_verification_email endpoint to send a verification email directly from Auth0, even when automatic emails are disabled.

Can you confirm whether you have configured your own email provider? The built-in Auth0 email provider is not for use in a production environment - a custom email provider should be setup to access the full features of emails:

setup to custom smtp … test mail working … api endpoint is working only if status is enabled … but i do not need verification mails to be sent automatically

1 Like