Overview
When trying to choose an application to add as the default application to a SAML connection under the IdP-Initiated SSO tab, the application is not showing on the list.
Applies To
- SAML connection
- Identity Provider (IdP)-Initiated Single Sign-On (SSO)
- Default Application
Cause
This is a known limitation in the product UI, the dropdown menu can only display the first 100 applications.
There is a backlog item to improve this. There is no ETA for when this will be implemented.
Solution
As a workaround, use the Management API and PATCH the connection using the following endpoint:
NOTE: The entire options object is overridden if the options parameter is used. All parameters must be present when using this option to avoid partial data or other issues. First do a GET to the connection and copy the entire option object.