Real-time Webtask Logs - Stuck at connecting

Last Updated: Aug 21, 2024

Overview

This article explains why the Real-Time Webtask Logs Extension displays a loading connecting icon but never seems to connect. Updating and reinstalling the connection does not fix this.

Applies To

  • Real-Time Webtask Logs Extension

Cause

The Realtime Webtask Logs Extension was most likely used behind a VPN, and when the VPN is disabled, the issues no longer exist.

Solution

There are some limits within the network topology when the app we use tries to stream logs from the server to the browser behind a VPN. Therefore, disable the VPN when using this extension.

No workaround exists outside of disabling the VPN when using the extension.