Real-time Webtask Logs - Stuck at connecting

Last Updated: Apr 1, 2025

Overview

This article explains why the Real-Time Webtask Logs Extension displays a loading connecting icon but never seems to connect. Updating and reinstalling the connection does not fix this.

Applies To

  • Real-Time Webtask Logs Extension

Cause

The Realtime Webtask Logs Extension was most likely used behind a VPN, and when the VPN is disabled, the issues no longer exist.

Another possibility is that a firewall in the network is actively blocking text/event-stream responses from Auth0.

Solution

There are some limits within the network topology when the app tries to stream logs from the server to the browser behind a VPN. Therefore, disable the VPN when using this extension.

If you have a firewall between the client and the Internet, try temporarily disabling it or testing in a network that does not have the firewall. This will confirm if the problem is with the firewall.

No workaround exists outside of disabling the VPN when using the extension.