Auth0 Home Blog Docs

Problems re-enabling Google social sign-in: redirect_uri mismatch

Hi,

I had Google social sign-in working fine until I tried passwordless SMS, disabled Google social sign-in, and cannot re-enable it successfully.

Current behavior:

image

On clicking to login, I get this screen:

Going to Google Console, the authorised redirect URIs are:

image

The “client-plans” URI is the one we are looking at. The form of the callback URI is the same as the Rails sample app on Auth0 site.

If I look at the app settings on Auth0, it is:

image

Which seems to properly list the “client-plans” URI.

I cannot see where the redirect URI listed in the Google OAuth error message:

The redirect URI in the request, https://dev-6a3k6-5p.au.auth0.com/login/callback, does not match the ones authorized for the OAuth client.

Has been set in my account.

The Google social provider settings have also been set for this application:

As mentioned: this was all working as expected until I disabled Google social login, enabled passwordless SMS, and then tried to re-enable Google social login

Is the application settings stuck in some kind of dev mode?

Thanks,
Daniel

It is possible but not 100% sure. Can you post a HAR file of your login attempt that fails? Also have you tried this in a fresh browsers or maybe incongnito/private window?

Hi @ashish,

Thanks for your prompt response.

Please see attached HAR file of failed login attempt accounts.google.com.har (245.5 KB)

I’ve tried this unsuccessfully on different browsers and also incognito/private window. The HAR file records an incognito session.

As mentioned, I didn’t have this problem previously, following instructions for Rails and OAuth2.

Much thanks :slight_smile:
Daniel