Google oauth is not working with auth0 dev keys

When trying to log into my app today for testing using a google account (and auth configured to use auth0’s dev keys), i am seeing the following error:

Error 400: redirect_uri_mismatch
You can’t sign in to this app because it doesn’t comply with Google’s OAuth 2.0 policy.
If you’re the app developer, register the redirect URI in the Google Cloud Console.

i even get this error using the “try connection” button when looking at the google oauth option in the social connections part of the auth0 dashboard

My initial impression is that this is something that I don’t have the ability to fix (besides providing my own keys for google Oauth). Is there a way to fix this that allows users to still do testing with auth0’s dev keys?

3 Likes

Getting same issue as of Aug 29

2 Likes

I got same error since AUG 27

1 Like

Try to add
Client ID and Client Secret from google in social connection page.

Get google Client ID and Client Secret
https://marketplace.auth0.com/integrations/google-social-connection

Hello everyone!

The issue with Dev Keys should be resolved now!

However, we recommend setting up your own keys, to avoid the limitations as per this article:

Thanks,
Art

1 Like

hi, i have an error with google login right now, i can’t login with a google account and i don’t get any errors, just does not login when i put all my data, and it shows the continue with google page again in an infinite loop

Hello, I’m still experiencing the same issue.

1 Like

Hi, still having the issue!!1
What could be the problem??

I followed the steps here to get a google client id and key and it’s finally working.

having same issue right now.

The same here right now.