Plugin v5 not showing on wordpress dasboard

Problem Description

The Auth0 plugin is installed and appears in the plugins directory but does not show up in the WordPress admin panel for activation.

Operating System:

  • Name: Debian GNU/Linux
  • Version: 11 (bullseye)

PHP Configuration:

  • Version: 8.2.13
  • memory_limit: 512M
  • upload_max_filesize: 80M
  • post_max_size: 80M


  • Database Server: MariaDB
  • Version: 11.1.3


  • Version: 6.5.3

Other Relevant Directories:

  • WordPress Installation: /opt/bitnami/wordpress
  • Plugins Directory: /opt/bitnami/wordpress/wp-content/plugins
  • Vendor Directory (within plugins): /opt/bitnami/wordpress/wp-content/plugins/vendor

Plugin Details:
โ”œโ”€โ”€ auth0 โ†’ โ€ฆ/vendor/auth0/wordpress (symbolic link)
โ””โ”€โ”€ vendor
โ”œโ”€โ”€ auth0
โ”‚ โ”œโ”€โ”€ auth0-php
โ”‚ โ””โ”€โ”€ wordpress
โ”œโ”€โ”€ autoload.php
โ”œโ”€โ”€ bin
โ”œโ”€โ”€ composer
โ”œโ”€โ”€ nyholm
โ”œโ”€โ”€ php-http
โ”œโ”€โ”€ psr
โ”œโ”€โ”€ psr-discovery
โ””โ”€โ”€ symfony

I ran it from the wp-content/plugins sub-directory.

composer require symfony/http-client nyholm/psr7 auth0/wordpress:^5.0

edit: corrected tree path

Hi @seranca, thanks for the detailed breakdown. Can you please open a shell, cd into wp-content/plugins/auth0, run composer install and see if that changes anything for you?

There is no folder Auth0, I made a symbolic link to try to make wordpress recognize the plugin.

plugins/auth0 points to /vendor/auth0

auth0 โ†’ โ€ฆ/vendor/auth0/wordpress

I run composer install but it wonโ€™t do anything as it is already installed

@evansims Thanks for your help. I solve it by restarting the apache server.

sudo /opt/bitnami/ restart apache

Hi, for anyone wondering.

The problem lies because Wordpress wonโ€™t detect the plugin. So creating a symbolic link or creating a custom Plugin Loader which summons Auth0 might do the trick

Hi @seranca :wave: Glad you got it sorted out!

A custom plugin loader and/or symlink should not be at all necessary, but the particular configuration of the server software youโ€™re using may have unique constraints around itโ€™s PHP search pathing. I only note it here as a caution, as that would not be one-size-fits-all advice to follow.

1 Like