Auth0 Home Blog Docs

Passwordless SMS login Signup not showing option to enter mobile number in LoginPage

passwordless
sms

#1

Hi,

I am developing a Xamarin App (cross platform) and would love to use the Lock Passwordless feature with just the SMS option enabled. I have tried setting up the PasswordLess connection to my client and can execute the APIs to Start the sms code sending process but I cannot use the Authenticate API since it supports the /ro legacy type grant.

So I decided to use the Auth0 built in widget, and I tried calling the URL to login with just the Passwordless connection enabled (setup with Twilio and can receive SMS), but the login page does not show the option for mobile number but shows “Something went wrong. Please contact technical support.”.
Has anyone done this before, can you please let me know what I am missing or what is the best way to accomplish this?

Note: I just want the SMS Login/Signup connection - nothing else.

Happy to hear out any suggestions even if this is done in the native way.

Thanks


#2

Just figured it out. I need to change the Client- Hosted Pages to have lock.sms for the Lock(Passwordless) option. Could have saved a day if there was right documentation done at the right places. I had to guess to get things going.


#3

Can you provide more information? I think I’m running into the same problem – but trying to use email / magiclink.

Thanks


#4

Can you provide more information? I think I’m running into the same problem – but trying to use email / magiclink.

Thanks


#5

Hi Devin

Try changing the hosted pages for Lock Passwordless.
If the HTML you provided still doesn’t appear, try disabling all other connections except Passwordless.

Once you change the connection give it a few minutes, just in case. Hope this helps.


#6