Don't see SMS auth for Passwordless for after sms gateway implementation

Hi team, removing Twillio sms service right now , because sms price to high for us .
And found Set Up Custom SMS Gateway for Passwordless Connections documentation how to implement SMS gateway

I faced with problem , that when I enabled sms provider , for Passwordless form I don’t see field where Im able to pass phone number for auth process. Only have to enable twillio sms again , how to avoid twillio and use custom provider and send sms through this provider?

Hi @maxymlrd_auth0

Welcome to the Auth0 Community!

First, the documentation you shared is the correct doc on using a custom SMS gateway provider other than Twilio for Passwordless login.

Now, if you’re having issues with the Passwordless form UI, then the problem is likely to do with the Universal Login Lock (passwordless) template.

After testing this myself, I was able to set up a custom SMS gateway and render the login page correctly. See below.

In this case, could you please try using the default Lock (passwordless) template to see if you can see the page correctly?

Looking forward to your reply.


so. its really not clear, I updated configuration for sms connection sms_gateway and etc.
I had to enabled applications , I did it , I can test and I received this message. Only one thing , why we doing it , but for this modal having SMS(Twillio) but it’s working without twillio api key ?

so , next step , I disabled my styles for login page and for classic and for new have password, don see sms at all
and one moment, if Im using default template from ur side , why I have predefined word Passwordless in input for password , how can I remove it ?

I disabled Customize Login Page , but still don’t have changes on login side.

Hi @maxymlrd_auth0,

Thank you for your response.

You’ll need to go to your Auth0 Dashboard > Branding > Universal login and select the Classic Universal Login in the settings and save the changes at the bottom. Then navigate to the Login tab and enable the Customize Login Page button and select the Lock (passwordless) template.

Once you’ve done that, please make sure to press the Save Changes button on the bottom of the page as well.

Please let me know how this goes for you.

Thank you.

for future connections , after update patch on connection with token ( described in article )
u have to go and enable sms trigger btn but not add twilio token , just make sure configuration same as on update patch , all applications enabled that u need in same modal , and if SMS trigger will be green u can enable Lock(Passwordless).
worked for me thx

1 Like

Hi @maxymlrd_auth0,

Thank you for your response and for providing additional context on the SMS Passwordless connection.

I’m happy to hear that everything is working now!

Please do hesitate to reach out if you have any further questions or concerns.

Thank you.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.