Password Reset Pages Shows Username Placeholder Instead of Username or Email Address

Overview

When trying to log in, the “Username or Email address*” placeholder can be seen on the login page:


When Forgot password? is clicked, the reset password screen only contains Username* in the placeholder instead of Username or Email address* :

Applies To

  • Tenant Admins
  • Reset Password
  • Attributes
  • Placeholders
  • Flexible Attributes
  • Attributes Configuration

Cause

The new attributes configuration is not activated. This is a known issue that can be found in Auth0’s official documentation - Issues using Flexible Identifiers:

“Identifier First prompts display all identifiers on the first screen and remove your previous settings, and the Reset Password prompt will display the input field to Username instead of Email.”

Solution

Activate the new attributes configuration following these steps:

  1. Go to the Auth0 Dashboard to Authentication > Database
  2. Click on the database connection
  3. On the database connection page, go to the Attributes tab.
  4. Click on the Activate button.
  5. Click on the Add Attribute button:
  6. Select Email .
  7. Have the option Use Email as Identifier enabled and click on Save .
  8. Make sure Username is included as an attribute and add it if is missing, following similar steps to adding Email.

Now, this placeholder should be visible when trying to reset the password: