Auth0 Home Blog Docs

Not able to set custom password length for Excellent policy level

I’m failing setting custom password length for the excellent level. The level defaults at 10 chars. We need 18. I can see that everything works in the playground while I set it, but it still defaults to 10 while I try to sign up.

There’s also no passwordLength key in password policy options object in the API.

{
  "id": "con_9dKKcib71UMRiHHW",
  "options": {
    "password_history": {
      "enable": true,
      "size": 5
    },
    "password_dictionary": {
      "enable": true,
      "dictionary": [
        "entry1",
        "entry2"
      ]
    },
    "password_no_personal_info": {
      "enable": true
    },
    "passwordPolicy": "fair"
  },
  "strategy": "auth0",
  "name": "MySQL",
  "enabled_clients": [
    "smTzlgPEdqGV0i070t6kPhmG98787987",
    "ztIyxRuiK7Pr2VTzEGvRqxfuh7DgePbF"
  ]
}

Thanks.

Hey, you need to set both the passwordPolicy and password_complexity_options.min_length parameters which looks like this

“options”: {
“passwordPolicy”: “excellent”,
"password_complexity_options": {
** “min_length”: 18**
** }**
}

https://auth0.com/docs/api/management/v2/#!/Connections/post_connections

1 Like

Thank you a lot Danco for sharing that knowledge here!

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.