My custom social login keeps getting "the connection is not enabled" error


I created a custom social login that points to my own server code. Everything was working fine on my local dev env. I tried pushing to our cloud dev env and it no longer works.

In order to test and debug the code locally I used ngrok and configure the custom social connection endpoints with my ngrok url (ngrok is a service that lets you have a valid internet url hit your local running ports). This all worked until I pushed to our cloud dev env and had to update the social connection endpoint urls. As far as I can tell, any time I try to using my custom social connection it stops at auth0 with the error “the connection is not enabled”. I have search and can not find any details about what this error means. Any help with this error would be greatly appericated.



Hey there @frank.wisniewski !

Quick question - for production, do you use the same auth0 tenant as for dev (where everything works fine)? You have a few tenants and the one for production do not have the custom connection you’ve mentioned and so it’s not enabled for the app in question.

Yes, we have multiple tenants, I was only trying to push to our dev tenant right now so our production will not have the custom socials yet. And yes, for my testing I use the dev tenant for my local code as well as our cloud dev instance of our code. I stated with just one custom social then when configuring it for our cloud dev instance I updated it with new urls and created a second one attempting to use the dev tenant for both local and cloud dev instance code. If that makes sense :smile:

So I figured it out, when I am calling the auth0 authorization endpoint and passing the connection parameter I did not get the case correct! I was passing all lower case but the custom social connection name I created was mixed case.

Lesson learned: custom social connection names are case sensitive! The error message was a little confusing because it should have told me the connection did not exist instead of not being enabled.

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.