Custom Social Login using PKCE

I have created a Custom Social Login. I can get it to work when the other IdP with PKCE disabled for the client that I created.

Auth0 has no way to allow me to turn PKCE on from a client of a social login.

Am I missing something? Is this just not implemented?

Hey there @david.hillier welcome to the community!

As far as I’m aware the only setting required for an Auth0 application is enabling the Authorization Code grant type.

Hi @tyf,

Sorry if I wasnt clear enough, I am not talking an Auth0 Application, but the Social Connection itself.

You can click “Try Connection” with PKCE disabled in the other IdP, it works. With it enabled it does not work.

There does not even seem to be a way to select that in the Auth0 UI as you would for an Application.