Minor issue with wordpress plugin

hello - first off, FANTASTIC JOB with the auth0 WP plugin! i can see where this is going to be extraordinarily useful.

this is minor, but wanted to mention it. if one is using any sort of login “rename” plugin, the logout callback stops working. for instance, we are using all-in-one security, and under “brute force” we have renamed /wp-login.php to something else that is much more difficult for a hacker to simply guess.

please see attached - you can see where our website is properly named, but i get a logout error.

thank you!

Hi edwardsmarkf, glad you like the Auth0 WP Plugin and Thank you for posting on Auth0 community!

I noticed that your settings page has the “Allowed Web Origins” as “https://css-cares.com”; but your plugin screenshot shows that your “Login Page URL” is “http://css-cares.com/”. Can you try to add “http://css-cares.com/” as an additional “Allowed Web Origins” url by comma seperating it from “https://css-cares.com” (since it is protocol specific). Let us know if that works!

i think i have made the changes but still see the same error:


any solution? i would like to move all of my wordpress sites over to auth0.

hi @ edwardsmarkf, apologies for the delayed response. Are you still having this issue?

If so, it looks like that issue might be related to your callback URL not matching the URL you are redirecting users to in your Wordpress site to upon login. Keep in mind you can have more than 1 “Allowed Logout URLs” by comma separating them. Make sure the include all possible callback urls, including the renamed logout URL in your applications settings page.

Let me know if that works.

hi - i am trying again, but this time with a different WP site, and run into the same issue with not being able to log out:

dev-2a5ae3w8

Oops!, something went wrong

There could be a misconfiguration in the system or a service outage. We track these errors automatically, but if the problem persists feel free to contact us.
Please try again.

i can “manually” log out by deleting all the cookies, but that seems pretty low-tech.

here is my configuration:

Application Login URI
https://englishwithoutaccent.com/wp-login.php

Allowed Callback URLs
https://englishwithoutaccent.com/index.php?auth0=1,
https://englishwithoutaccent.com/wp-login.php?action=logout,
https://englishwithoutaccent.com/wp-login.php

Allowed Logout URLs
https://englishwithoutaccent.com/wp-login.php?action=logout,
https://englishwithoutaccent.com/wp-login.php

please share any more suggestions. i feel as if we are VERY CLOSE to getting this resolved.:grin:

Is there anything in the logs: Auth0 Dashboard > Logs ?
In case you see a failure, click on it to see details

1 Like

logfiles… who knew…? :smiley:

THANK YOU!

EDIT: this is a bit more difficult for me, as i have already done php and npm grant-profiles.

these are the steps i went through to get things working:

2 Likes

Glad you have it working!

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.