Auth0 Home Blog Docs

Mgmt API returns new DB connection, but it doesn't appear in the dashboard

I’m trying to create/update a database connection via the Management API. The create and update calls return successfully (200). When I get all the existing connections, the API returns my new one. All good.

However, when I go to my tenant dashboard, the Connections page doesn’t show my custom connection.

The payload I’m sending (on the update) is:

{
    "options":  {
                    "passwordPolicy":  "fair",
                    "import_mode":  true,
                    "enabledDatabaseCustomization":  true,
                    "customScripts":  { ... }
                },
    "enabled_clients":  [ ... ]
}

Am I missing something that makes it appear in the dashboard? I haven’t had any problems with anything else. I’ve already been able to configure email provider, email templates, applications (clients), APIs (resource servers), and rules, and everything else has shown in the dashboard immediately.


Edit

It looks like the payload above is my “update” payload. The “create” payload also includes "strategy": "custom".

I create connection (DB) regularly through Management API and haven’t seen this happen so it may need a very specific set of conditions to reproduce. Can you perform the following:

  1. open the dashboard in the social connections view.
  2. open the browser network tools.
  3. select the database connections view.

The above will result in a network call to obtain connections; the first things to check is to see if the connection in question is returned at the network level. If it is, then see if there are any errors in the browser console after navigating to the database connections view.

Also note, that the result set is paginated so it may be important for you to share how many DB connection you already have in that tenant.

It looks like it may not be returned:

https://manage.auth0.com/api/connections?fields=name&strategy[]=auth0&include_totals=true&page=0&per_page=100

This only returns the default “Username-Password-Authentication” connection. (I only have that one and my new one, so paging isn’t an issue.)

Interestingly, the call that’s being made is filtering on the auth0 strategy. Mine is a custom strategy. Where would I find this in the dashboard?

Edit

Even when I use auth0 for the strategy, it still doesn’t appear in the dashboard.

Edit 2

I had tried to update the strategy, which isn’t allowed. When I deleted the connection and recreated it with the auth0 strategy, it appeared in the dashboard. So this problem is solved.

However the question still remains: where does one find custom strategy database connections in the dashboard?

A custom database connection will still use the strategy auth0; what makes it a custom database connection are other settings within the connection options so strategy should be the auth0. The custom strategy you likely set during creation is something completely different and likely the source of the confusion because the dashboard won’t have any section for this.

Not all connection types have support on the dashboard, one current notable example, are any custom OAuth 2.0 connections which would need to be managed by the API or using an extension.

1 Like

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.