Linkedin OAuth failing with error_description: "[object Object]"

Howdy -

I’ve been having trouble with my LinkedIn Connection ever since I switched over to “Strategy Version 2” a few months ago. It seems that every time I attempt to authenticate with LinkedIn, or test using the “Test” button on the configuration screen, I receive an error with body

{ "error": "access_denied", "error_description": "[object Object]" }

(also see screenshot)

Things I have already tried:

  1. Generating new API Keys
  2. “Verifying” my application on LinkedIn (company admin portal)
  3. Inspecting the error message on the front end (spoiler: the error_description is already a string, so I can’t see what’s in that object)
  4. Turning it off and back on again

Has anyone seen this before? What could possibly be the matter?

  • Adam

An access denied error like that can come from rules setup within your own tenant so if you haven’t done so already I would check if you have rules enabled and if yes, try to do a quick test with all rules disabled just to confirm if they can be the source of the issue or not.


Thank you! I had one of the canned LinkedIn Rules active, disabling it solved the problem! Thank you, and sorry about the late response!

1 Like

Thanks a lot for letting us know and sharing what was wrong with the rest of community!

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.