How to enable public sign-up

Hello,
I am not able to locate where I can enable the “public sign up”.

As of now, the login widget throws an error “public signup is disabled” when I enter a new email and click on “sign up”.

Every post on this topic seems to points to an older version of auth0 dashboard where there was a “connections” tab on the left sidebar where you can enable/disable the “public signup”.

Where is this option in the latest version of the auth0 dashboard?

Thanks

Hi @rakesh.iitm,

Welcome to the Auth0 Community!

If you navigate to the settings page for the connection you are working with you will see a ‘disable signups’ toggle.

1 Like

Please help me locate.
Attached screenshot. This is all I see for the application “connections” page.

I checked the “settings” page including the last section “Advanced”.

I am going:
Applications → “Default App” → Settings.
I see sections like “Application Properties” … “Refresh Token Rotation” , “Advanced” etc.
But there is no “Disable Sign Ups”. [To remind, I want to enable sign ups]
Is it missing some config from my side?
I am able to test “login with google” end-to-end.

Only “signup” is not working.

Here I am assuming a new user should be able to signup by verifying email.
And the user database will remain with auth0 but I should be able to fetch user information same way I am doing for a “login with gmail” user.

@dan.woda please point me to the relevant doc.

Yes, you need to go to the connection settings, not the application settings. You can find the connections under the Authentication tab on the left hand nav bar.

1 Like

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.