Auth0 Home Blog Docs

Grant type 'http://auth0.com/oauth/grant-type/passwordless/otp' not allowed for the client

Hi, I’m getting the error above when trying to authenticate user using password-less method
I got the sms code when i hit the “passwordless/start” endpoint, however, I’m unable to authenticate.
I am following this document guide

This is my payload, redacted (xxxxx).

grant_type:http://auth0.com/oauth/grant-type/passwordless/otp
client_id:XXXXXXX
username:XXXXX (phone number)
otp:1111111
realm:sms
audience:https://xxxxxx.auth0.com/api/v2/
scope:openid profile email
client_secret:xxxxxxxx


{
    "error": "unauthorized_client",
    "error_description": "Grant type 'http://auth0.com/oauth/grant-type/passwordless/otp' not allowed for the client.",
    "error_uri": "https://auth0.com/docs/clients/client-grant-types"
}
1 Like

You’ll need to enable the grant type explicitly for the application, under Advance Settings | Grant Types.

Client responded via email:

Thanks Nicolas but I don’t see that options in my advance settings page of the application.

Hello @nicolas_sabena, just following up with this. Did you have an idea why it’s not showing up in my account?

Thanks
Ebenezer

Hi @nikiben. Sorry about that, I did not get your message about not seeing the grant type.
What’s the application type you have selected? It should be visible for all app types except “Machine to machine application”. It’s probably also disabled if the application type is not specified.

2 Likes

Yes that works! Choosing the regular web app type made it visible.
Thanks @nicolas_sabena for your help!

2 Likes

Glad you have it working @nikiben!

I was just going to ask the same problem and then I found this solution. However, I can’t seem to be able to set the grant types for my application. I can open the advanced settings and then tick the otp grant box but when I try to save I get an error:

Error! Invalid grant types: http://auth0.com/oauth/grant-type/passwordless/otp

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.