Getting RS256-encrypted JWT for Custom SMS Gateway

Hey team! I’m running into a super weird issue regarding the JWT that’s returned for our team’s customer SMS gateway. I’ve followed Set Up Custom SMS Gateway for Passwordless Connections to the dot and gotten to a point where I am correctly hitting our gateway with the right Auth0 phone number and message. However, the JWT coming in is always coming in with HS256 when our Auth0 Machine-to-Machine and backend both expect RS256, which is the default. These are the values I’m sending down in the connection options for “gateway_authentication”. Is there anything else I can pass to enforce RS256?

This is a hard blocker so we really appreciate any and all help! Thank you :slight_smile:

"gateway_authentication": {
    "method": "bearer",
    "subject": "RsgsVQR.....mBUUP5bjb",
    "audience": "https://[our_domain]",
    "secret": "kQ8KS9ArZX........1LBeu1nh",
    "secret_base64_encoded": false

cc @konrad.sopala since you were commenting on some relevant threads. Would love your help or if you know someone who has context here!