Auth0 Home Blog Docs

Expected 1 '.' in the input between the postcard and the payload

google-authenticator

#1

Hi there,

I’m trying to setup a Google social connection. I followed the instructions in the https://manage.auth0.com/#/connections/social section (there’s a video there) and it should be straight forward but am hitting a road block. When I “try” to test my connection I keep getting the error below.

{
  "error": "access_denied",
  "error_description": "Expected 1 '.' in the input between the postcard and the payload"
}

I can provide more details as necessary, but shouldn’t be this hard. I created a project in google, setup my oAuth creds, entered my client id / secret and that should be it.

Any thoughts or tips?

Thank you,

Matti


#2

Hey there @matti, I see your have an open support ticket and I’m sure support will be reaching out to you soon in regards to this matter.

In the mean time, were you able to select the permissions when setting up the connection that your app was able to have access to? Thanks in advance!


#3

Hi James,

I was able to select permissions, but it didn’t make a different. I still was receiving the same error. :confused:

Thank you!

Matti


#4

This was an issue with our custom Rules. After adjusting our rules, the authentication mechanism worked like a charm. Thank you for the help!


#5

I’m glad to hear it all came together @matti! Let me know if you have any questions in the future! Thanks!