Auth0 Home Blog Docs

Error while trying to login with facebook app (lock for web)

lock
auth0
login

#1

Hello everyone, we are having some issues while trying to login with auth0 lock with facebook… in desktop it works OK, but in mobile, in some devices it launches facebook app and then it opens a internal browser and it shows the following error.

any idea how to sort out this error?

Thanks in advance


#2

Hi. Have you checked your tenant logs to see if there’s any error logs that might provide more details?


#3

Hello, I have the same problem. Has anyone found a solution? The error occurs exclusively in Chome. I can not see any mistakes in my log.

the login via the Facebook app always has a Funktioneist. It has not worked for a few days.


#4

I do not know if it helps but:
To test, I have the Facebook login without Auth0 built into my website, with the Facebook PHP SDK. I have used this guide:
https://developers.facebook.com/docs/php/howto/example_facebook_login?locale=de_DE

Below I found out. The same error occurs. If you log on to the Facebook app and not via the web browser, the login will not work.

I found out that when returning from Facebook to my server, the session / cookie data is lost …

I was able to avoid the error with the following link:

I think it’s a server issue with Auth0 or something with the Facebook app…


#6

I’m also having this issue. No useful info found tenant logs other than ”Permissions error”, but that’s not the only time the error happens.


#7

New insights. Today there was a Facebook app update (177.0.0.57.105). Now the login works with Auth0 and Facebook again.
To make sure that it was mainly due to the Facebook app, I have installed an older version of apkmirror.com (176.0.0.42.87). And yes, with the older version it comes back to the error, with the newer not.