Auth0 Home Blog Docs

Error when trying to change social connections

Whenever trying to turn on or off a social connection I get the warning “Error! Bad Request. Please contact support if the problem persists”. Image: https://i.imgur.com/gK6hL0H.pngAuth0%20Error2

I am trying to turn on Microsoft connection, and turn off Google. But this also happens for every other social connection I’ve tried.

I just started this account today and verified my email. Could there be something with being a new account?

Thank you

Not sure why you’re getting this, but note that you can also enable/disable connections per app from within the Dashboard through the > Applications > EMR App > Connections instead of Dashboard > Connections path. Does that throw the same error?

Additional things to check:

  • Does the error only occur for the Microsoft Account or also other connections?
  • Any browser add on getting in the way maybe?

Hi mathiasconradt, thank you for replying quickly.

I tried going through the way you said and changing the connections from within the app settings. However I get the exact same result. An error it thrown and it automatically resets the little toggle slider.

As you can see this happens for all connections, including trying to turn off Google. I also tried it on Microsoft Edge and Mozilla Firefox browsers to the same result.

Ok, that’s weird. Anything to see in the developer tools console of the browser? But may indeed be something for support. Cannot reproduce the issue in my tenants.

1 Like

There was/is, and that just lead me to find what I believe is the cause. Which is my work network’s very stringent security policies. Here are the errors that came up in the dev console when trying.

Auth0%20Error3

I decided to remote into my home computer and try it. That worked with no issues. I’ll be working with my network admin to see if we can get it white listed.

Thank you for your help! It put me on the right track.

1 Like

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.