Error "The credentials have expired" on MFA Page

Last Updated: Nov 29, 2024

Overview

When the user tries to log in, the MFA page displays the error message:

The credentials have expired.

Applies To

  • Expired Credentials
  • MFA

Cause

This error is thrown by the auth0-guardian SDK if the MFA token is expired (see the Related References section for reference). The most common cause is the clock on the user’s device/machine is out of sync (clock skew).

Solution

This is an error thrown by the MFA widget, and it is caused by a clock skew on the user’s device. The user will need to make sure they have the correct time set and that their device’s time is synced with an NTP server.

NOTE: TIME.IS is a very useful website for checking the current time and the time difference between the local machine and the standard time.

Related References

1 Like