Error in installing SSO Dashboard extension

Hi All,

I have been trying to install the SSO dashboard extension following the steps from this link -> https://auth0.com/docs/extensions/sso-dashboard , but I haven’t been successful (“Error trying to install SSO Dashboard. Please try again later.”)

I have followed on the trace and I can see that error (Err:500) happened when doing a POST to our sandbox (**/auth0-sso-dashboard/.extensions/on-install) with error message “{“error”:“InternalServerError”,“message”:“Identifier ‘u’ has already been declared”}”.

Has anyone encountered the same issue?

Regards,
Keith

  • stacktrace

    error: SyntaxError: Identifier ‘u’ has already been declared
    at /data/io/0bf6530c-9ca7-8dfbb0a914f5/webtask.js:1:20994
    at Layer.handle [as handle_request] (/data/_verquire/express/4.12.4/node_modules/express/lib/router/layer.js:82:5)
    at trim_prefix (/data/_verquire/express/4.12.4/node_modules/express/lib/router/index.js:302:13)
    at /data/_verquire/express/4.12.4/node_modules/express/lib/router/index.js:270:7
    at Function.proto.process_params (/data/_verquire/express/4.12.4/node_modules/express/lib/router/index.js:321:12)
    at next (/data/_verquire/express/4.12.4/node_modules/express/lib/router/index.js:261:10)
    at Function.proto.handle (/data/_verquire/express/4.12.4/node_modules/express/lib/router/index.js:166:3)
    at router (/data/_verquire/express/4.12.4/node_modules/express/lib/router/index.js:35:12)
    at Layer.handle [as handle_request] (/data/_verquire/express/4.12.4/node_modules/express/lib/router/layer.js:82:5)
    at trim_prefix (/data/_verquire/express/4.12.4/node_modules/express/lib/router/index.js:302:13)
    at /data/_verquire/express/4.12.4/node_modules/express/lib/router/index.js:270:7
    at Function.proto.process_params (/data/_verquire/express/4.12.4/node_modules/express/lib/router/index.js:321:12)
    at next (/data/_verquire/express/4.12.4/node_modules/express/lib/router/index.js:261:10)
    at /data/_verquire/express/4.12.4/node_modules/express/lib/router/index.js:603:15
    at next (/data/_verquire/express/4.12.4/node_modules/express/lib/router/index.js:246:14)
    at Function.proto.handle (/data/_verquire/express/4.12.4/node_modules/express/lib/router/index.js:166:3)
    at router (/data/_verquire/express/4.12.4/node_modules/express/lib/router/index.js:35:12)
    at Layer.handle [as handle_request] (/data/_verquire/express/4.12.4/node_modules/express/lib/router/layer.js:82:5)
    at trim_prefix (/data/_verquire/express/4.12.4/node_modules/express/lib/router/index.js:302:13)
    at /data/_verquire/express/4.12.4/node_modules/express/lib/router/index.js:270:7
    at Function.proto.process_params (/data/_verquire/express/4.12.4/node_modules/express/lib/router/index.js:321:12)
    at next (/data/_verquire/express/4.12.4/node_modules/express/lib/router/index.js:261:10)
    at urlencodedParser (/data/_verquire/body-parser/1.12.4/node_modules/body-parser/lib/types/urlencoded.js:91:37)
    at Layer.handle [as handle_request] (/data/_verquire/express/4.12.4/node_modules/express/lib/router/layer.js:82:5)
    at trim_prefix (/data/_verquire/express/4.12.4/node_modules/express/lib/router/index.js:302:13)
    at /data/_verquire/express/4.12.4/node_modules/express/lib/router/index.js:270:7
    at Function.proto.process_params (/data/_verquire/express/4.12.4/node_modules/express/lib/router/index.js:321:12)
    at next (/data/_verquire/express/4.12.4/node_modules/express/lib/router/index.js:261:10)

Hello,

I get exactly the same error as you, did you find a way to make it work properly?

Thank you.

Regards,
Thibault

Hey there!

Sorry for such delay in response! We’re doing our best in providing the best developer support experience out there, but sometimes the number of incoming questions is just too big for our bandwidth. Sorry for such inconvenience!

Do you still require further assistance from us?