Auth0 Home Blog Docs

Error connection in rule

custom-db
rules
roles
database-connections

#1

#Eyh everyone

Im new user of auth0, i try to use specific rule (‘Add user roles from a SQL Server database’).
For that, i use free plan from heroku for pgsql database. But when i try to set the values for the connection into the rule, i get errors.

the first:
ERROR: connection to ec2-54-217-235-137.eu-west-1.compute.amazonaws.com:1433 - failed Error: connect ECONNREFUSED 54.217.235.137:1433

(So i say me its because the port isn’t good, so i put in options: port: ‘5432’)
but when i do this, i get :
ERROR: Request to Webtask got ESOCKETTIMEDOUT

Im very confused and the debug log doesn’t help me.

Who can help me please ?

Thx !
PS: Im french, so excuse me for my bad english and tel me if i have make mistakes :slight_smile:


#2

:wave: @erwandelbrouque Request to Webtask got ESOCKETTIMEDOUT is commonly thrown when there is an issue in requests made from something like a custom database connection script, hook, or another rule.

We can check our Rules and Hooks and see if they are working as expected. We can do this by adding console.log() statements and monitoring the output using the Realtime Webtask Logs extension to debug.

Another way to check would be to disable all Rules and test; if successful, the issue points to one of your Rules. You could then enable them one by one until you find the one that throws the error again.

Please let me know if you are able to pinpoint the issue while trying the above.

Also, your written english is very good! :+1:


#3

Eyh @kim.noel, thank for the answer !

I have already tested with logger but i haven’t seen anything who let me think i have do something wrong in the rule.
i’m haven’t turn on the rule, i have just trying to work the rule by testing on the dashboard. Im sur it was only this rule who go bad. I while continue to debug the rule, maybe i forgotten something :slight_smile:

thank !


#4

@erwandelbrouque were you able to solve your issue?