Problem Statement
The Auth0 emails (code or magic link, verification, etc.) are not received but tenant logs show successful logs that emails are sent.
Symptoms
- Email message is not received.
- Auth0 Tenant Logs doesn’t show failed sendings.
Cause
If tenant logs show successful email delivery, there may be an issue with the SMTP provider configured for the tenant.
Solution
Check the following:
- If only one or a few users are affected, the email may have gone into their spam folder
- Check the sender’s email in the Email Provider
- Check the logs in Email Provider for messages related to the successful logs from Auth0
- Consult Email Provider documentation on errors that might arise in the logs
- Contact Email Provider support