Emails Not Received Even If Tenant Logs Shows Success

Problem Statement

We don’t receive any Auth0 emails (code or magic link, verification, etc.), but tenant logs show emails are sent successfully.

Symptoms

  • Email message is not received.
  • Auth0 Tenant Logs doesn’t show failed sendings.

Cause

If tenant logs show successful email delivery, there may be an issue with the SMTP provider configured for the tenant.

Solution

Please check the following items in the Email Provider:

  • Check the sender email in the Email Provider
  • Check the logs in Email Provider for messages related to the successful logs from Auth0
  • Consult Email Provider documentation on errors that might arise in their logs
  • Contact Email Provider support if none of the others thrive results