Email Verification of new member not working

When we add a new member, it asks us to enter their email AND password. Firstly, I found it strange we enter a password and they still get a verification email.

But they are not then getting a verification email. A couple of us have tried using several different emails (organisation and personal) and no email is sent. Not in spam either. Clicking to resend the email, which even says in the popup “Resend” does not resend it.

As we entered the password we can email the user the details, but that really is not a good way to do it. We should not know their passwords, nor should we be emailing them.

So it seems to me there is an issue with the system.

Does anyone else have this issue?

Hi @laurence,

Welcome to the Auth0 Community!

Whenever you create a user on their behalf, you must provide an email address and password. This is required for database connection users. Once the user is created, a verification email is sent automatically.

However, you could optionally stop the verification email from being sent during account creation. You would need to pass in the verify_email: false parameter.
image
(Reference: Auth0 Management API v2)

Now, if you’re having issues with sending emails, I suggest using a custom email SMTP provider instead of the Auth0 built-in provider.

The built-in provider is typically meant for testing purposes and not for production. There could be scenarios like the one you experienced with email delays and interruptions.

Could you give that a try and let me know how it goes for you?

Thanks,
Rueben

Thanks for your reply. I am not sure this is in relation to the issue. So if I login to the dashboard here https://manage.auth0.com/dashboard/, in which I manage users that can login through my app, and I add a user in User Management → Users, then no email is sent to them. Even if we click to resend, and the statement implies an email was sent before, an email is still not sent.

So we are not using any code/api. We do not pass parameters like verify_email.

We use Auth0 to just allow people to login to a custom website we have to access private data. Its only an authentication method.

Hi @laurence,

Thanks for your update.

I have checked your tenant settings and found that you have disabled the Verification Email (using link) email template.

In this case, you’ll want to head to your Dashboard > Branding > Email Templates > Verification Email (using link) and enable the template.

Once that’s done, newly created users will receive the verification email.

Thanks,
Rueben