Email Not Sent Error: "Missing MX and A Records"

Last Updated: Nov 4, 2024

Overview

How can the missing MX and A records error be found in logs when trying to send an email to a user be resolved??

Steps to reproduce the error:

  1. Ensure a custom email provider is configured on the tenant and that the verification email template is enabled. With a database connection, complete the sign-up flow with an email address that has a good domain to confirm that your setup is working (example: ellen.conley@okta.com).
  2. With a database connection, complete the sign-up flow with an email address that has a bad domain. For example: ellen@hotmail.cin
  3. Check Monitoring > Logs for the error > type: "fn" AND details.error: "missing MX and A records"

Applies To

  • Custom domain
  • Email template
  • Tenant logs

Cause

Before attempting to send an email via SMTP. first run a DNS query to ensure the domain on the recipient’s email address has either an MX or A record in order to reduce the number of bounced emails.

First check if the email domain has an MX record, and if not, check for an A record. If both are missing this error is returned.

Solution

This error could be:

  • User error - they tried to sign-up, but the domain on their email address included a typo.
  • The email administrator did not configure the domain on the recipient’s email address properly.
  • A malicious user tried to create an account with a bad email address for a phishing attempt.

Make sure an MX or A record is set on the user’s email domain.

Related References