Email Delivery Fails with Error "The provided authorization grant is invalid, expired, or revoked"

Last Updated: Aug 2, 2024

Overview

This article describes the issue in which Sendgrid is configured as their SMTP provider, but emails are not being delivered. The following error message is seen:

The provided authorization grant is invalid, expired, or revoked.

Applies To

  • SMTP Provider
  • Email Deliverability

Cause

This error seems to be returned by Sendgrid when we attempt to deliver the email using the API key you have provided. Sendgrid is rejecting the API key.

If this used to work before, it is likely that the key is now revoked or expired.

Another cause could be that the API Key ID was copied instead of the Key value, in which case they would need to generate a new key and make sure to copy the value.

To troubleshoot and confirm this issue:

  • Go into the tenant’s log and search for type:“fn”. The logs will show the error message:

    The provided authorization grant is invalid, expired, or revoked.

Solution

To solve this issue, attempt to create a new Sendgrid API key in case the previous one has been revoked or expired.

Related References