Directly redirect to linkedin, without going to auth0 login page first

I am using auth0 to set up LinkedIn as a social identity provider in an Amazon Cognito user pool. I followed the steps provided in this article to set it up:

How do I set up LinkedIn as a social identity provider in an Amazon Cognito user pool?

It works fine but I want to automatically redirect users to Linkedin, instead of showing the auth0 page and a linkedin button in the bottom of that page…

Hi @hamed,

It sounds like you might be looking for an embedded login instead of using the Universal Login. Universal login is recommended for security and other reasons, but it is possible to add a social connection login button on your app directly.

You can read more about Embedded vs. Universal Login here:

You can use either the Lock.js or Auth0.js SDKs on your web applications to implement embedded login.

Note: As mentioned in the docs, there are security concerns with the embedded login approach, especially without using Custom Domains.

No problem! There is information for mobile applications in the Embedded vs. Universal Login page above.

The React Native quickstart points out the following options:

You can also embed login functionality directly in your application. If you use this method, some features, such as single sign-on, will not be accessible. To learn how to embed functionality using a custom login form in your application, follow the Custom Login Form Sample. Make sure you read the Browser-Based vs. Native Login Flows on Mobile Devices article to learn how to choose between the two types of login flows.

it seems it is not working with aws and cognito…

Hi @hamed ,

In your authorization request (redirect to “/authorize” endpoint), specify the connection parameter as “linkedin”.

For example, your /authorize request should look like

https://<YOUR_DOMAIN>/authorize?
    client_id=<YOUR_CLIENT_ID>&
    connection=linkedin&
    scope=openid profile email&
    redirect_uri=https://YOUR_APP/callback&
    state=STATE&

Hope this helps!

Hi supun,
I don’t find any authorization request that I can pass the connection parameter to it. If you mean in the application code I did not set any endpoint, all of my configurations are set through AWS, linkedin, Auth0 panel.