Last Updated: Aug 6, 2024
Overview
During an operation related to a user from a custom database connection (such as reset password, for example), the following error occurs:
DB Get user Custom script: Please verify the provided email/username or password
The Import Mode is turned on.
Applies To
- Custom DataBase (DB)
- Password Reset
Cause
This can happen when a different email address is sent for a particular user ID, and there is already a record of one email address. This can happen, for example, when the user’s email address changes in the legacy DB, but there is already a shadow profile in Auth0 with the old email information.
Solution
The delete connection user by email API endpoint can be used here to clean the shadow user. Refer to Delete a Connection User for more details.