Auth0 Home Blog Docs

Cordova Phonegap login authentication link problem

Hi there,

I’m trying to perform auth0 login authentication on cordova phonegap app and problem is whenever I tap on compiled android app auth0 icon it prompts me “open with” dialog box, how can this be avoided, and how to make it work properly ?

thanks

Hi there @dsel and welcome to the Auth0 Community!

I wanted to confirm with the error you are encountering that you have modified your config.xml file? I have include our Cordova Quickstart for a quick point of reference as you venture forward. Thanks!

Hi James, thanks for the response.

I did follow both Single page app as well as Cordova app (since we’re working with phonegap) instructions and I did set in config.xml but nevertheless “open with” still remains.

When you get a chance can you snag us a screen shot @dsel and any additional details that may help us nail down what is occurring? Thanks in advance!

Hi James,

Here’s images explaining four crucial steps in the problem we’re experiencing:


(js files included in main index.html file)


02-auth0-webAuth-init
(webAuth initialization)


03-auth0-fb-button-handler
(facebook login button handler)



(the issue occurs - the actual problem we’re facing, this is an android emulator screenshot, but the behaviour is the same on native android phone)

thanks.

After so more investigation it appears this has come up before as seen in this Community post here which might be worth testing.

In the event this doesn’t remove the blocker, can you please direct message me the tenant name? Thanks!

Hi James, thanks for the response,

I actually found the same potential solution to the problem as you suggested, but on a different forum, unfortunately that doesn’t do the trick for me…

hey guys, any clues on this one?

thanks.

Have you by chance installed the safariviewcontroller plugin?

cordova plugin add cordova-plugin-safariviewcontroller

Still investigating overall.

Yes I’ve tried safariviewcontroller as well as cordova-plugin-inappbrowser together and one at the time, still didn’t worked properly.

Thanks.

Following up @dsel, It looks like when investigating your tenant that it is missing the package name and hash on the Auth0 side of things within the dashboard. Please update this under the Advance tab and place in the package name and hash. Please let us know after doing so if it has helped unblocked you. Thanks!

Hi James, thanks for the suggestion but unfortunately that still doesn’t fix the problem…

(BTW application ID we’ve been using is starting with RX9)

Hey @dsel,

After speaking with one of our engineers have you been able to configure the Android app settings to always open with the preferred option? What version are you currently running with Android? Still trying to get to the bottom of this with you. Thanks!

Hi @James.Morrison,

My name is Dejan Markovic and I am co-founder and CTO of https://socialwebsuite.com/.
We are being blocked by this issue for weeks and it’s coming to a point where we will have to decide if we are going to use the Auth0 or have to move to other solution.

Would you be able to connect my Dev team with your Dev team so we can solve the problem together as soon s possible please? If we need to pay for the consultation fee I am OK with that if the cost is reasonable.

Would you guys be able to help us out?
Thanks

Hey there @dejan and @dsel,

I am currently working with our sales team to see how we can get you connected to our elevated support team.

In the meantime, @dsel have you been able to configure the Android app settings to always open with the preferred option? Any details on the version are you currently running with Android would be helpful as well. Thanks in advance!

1 Like

@James.Morrison Thank you for the feedback. I have just added my credit card info and now I am waiting for that to go trough your system. I’ve got the message that it takes 2 hours for that. As soon as my cc is approved I will buy the Developer plan. I will let the @dsel reply with the info he has regarding the APP. Thanks

Sounds great @dejan and please let me know if you have any questions @dsel about my request!

Hi @James.Morrison,

We have bought the Dev package, than you! :slight_smile:
We are unable to find the where is ‘always’ open with preferred option located. Can you please help us out?

We are testing on Android 6,7,8 and 9.

Thank you!

I believe this article dives into it here.

Please let me know if this helps.

Hi James this is the response when I proceed beyond ‘Open With’ dialog