Auth0 Home Blog Docs

Auth0 Cordova unable to open login

Wondering if anyone has run into issue with Cordova before. It might have to do with Safari view controller plugin for cordova. Whenever I initiate the .authorize({}, callback) method for @autho/cordova, it opens up safari view controller window, however, it does not open any webpage, and the app eventually crashes. Maybe b/c I’ve only tried that in the emulator for iOS, but I’m thinking it should still work. It’s happening on Android as well, tried that on a real device.

Also, on the dashboard, whenever I set callback uri for a native application in the following format PACKAGE_ID://AUTH0_DOMAIN/cordova/PACKAGE_ID/callback, I get an error message on the page saying callback uri must be a valid format.

Any help is appreciated!

Hey there @hersh.amin!

Sorry for directing you to a different place but I think it will be more helpful and quicker if you open an issue in the GitHub repo: https://github.com/auth0/auth0-cordova so that you can take a look at it with the tool maintainers and get it sorted!

Hi @konrad.sopala!

I don’t think the issue is about Cordova not being able to open up, I fixed that, turns out the code I had was causing some memory leaks. But the issue on the Dashboard remains, where I’m not able to set the callback url for Native apps in this format PACKAGE_ID://AUTH0_DOMAIN/cordova/PACKAGE_ID/callback. Also whenever I use auth0 cordova, which opens up the hosted universal login page, it has the same type of message there with an error page. The message I get there is The redirect_uri" parameter is not valid.

I think it has to do with some bug in dashboard code or my setup, I’ve set the application as Native on the dashboard, not sure what else needs to be done.

Hey @hersh.amin!

Can you tell me whether you’re using any of our quickstarts / tutorials ? Asking cause I would like to go step by step and debug the process on my computer and see what can be done. Thank you!

Hey there!

Have you had a chance to see my previous message?