Configuring Passwordless OTP to use SMS and Email with Universal Login

I would like to use the Universal Login page and Passwordless OTP with SMS and Email connections to allow my users to login with either their phone # or their email. I’m not sure this is possible though. Every article I’ve found so far mentions SMS or Email implying not both. This is the only one I saved the link for but I’ve seen it several other places Configure Universal Login with Passwordless.

Furthermore when I setup the Universal Login for my application and turned off all the connections other than SMS and Email in Application > Connections. When trying to login the Universal Login page only shows an email address login option.

I can implement a custom UI that accepts an email or phone # and make the necessary API calls to get the user authenticated but I would much prefer the simplicity of the Universal Login.

Can anyone tell me if I can enable both of these connections for Passwordless OTP and still use the Universal Login?

Hi @Derek-1337 ,

Welcome to the Auth0 Community!

If I understand correctly, you want to set up the Passwordless connection for both SMS and Email, and users need to fill in the code from both connections to log in.

I just tested this use case, and it works for me. Here are my configuration details:

  1. Enable both SMS and Email under the Passwordless connection
  2. Enable the Customize Login for lock passwordless under Classic Universal login
  3. Enable both SMS and Email passwordless connections for the application.

If your use case is to enable both SMS and Email, and users can log in by entering code from either connection, currently, we don’t support this feature. Please feel free to provide the feedback to our Product team here.


Thanks @lihua.zhang for the configuration details.

My use case is that I would like a user to sign in with their email OR their phone # and enter the OTP from whichever method they chose.

Using the configurations you provided I still only had the email option available on the Universal Login page.

I’m still very new to Auth0 and I’m not clear on the terminology so maybe I haven’t followed the instructions correctly.

What I did

Under Applications > Connections I enabled email and sms connections.
Under Branding > Universal Login > Settings I switched the the Classic Experience
Under Branding > Universal Login > Login I enabled Customize Login Page, but I didn’t change the template at all.

Could you please DM me the name of your tenant and the application? Thanks!

Hi @Derek-1337 ,

Thank you for providing additional context.

I checked the application and noticed that only Email is enabled. Could you please open the application settings → Connections Tab and make sure both SMS and Email are enabled?

I believe this change will solve the issue. Please let me know how it goes. Thanks!

This topic was automatically closed after 9 days. New replies are no longer allowed.