Overview
Sometimes Admins need to make changes to the properties SSO Integration we have in our library:
This need can arise for a number of reasons. Sometimes, the fields provided by Auth0 do not fill in all the parameters required by the third-party application to authenticate, and users encounter an error with single-log-in or single-log-out, for example:
missing client.addons.samlp.logout.callback
All available parameters for the SSO Integration can be seen under the relevant Application in the Addons tab.
Applies To
- SSO Integration Properties
- Management API
Cause
For third-party SSO Integrations in the library, Admins use a wizard to fill in relevant parameters. Sometimes, third-party applications need parameter values that cannot be set through this wizard.
Solution
- Set up an API token and navigate to the Management API docs (or use the software of your choice) and use the /clients endpoint: Get client by ID
- Get the client_id for the SSO Integration via the Auth0 Dashboard.
- Get the call get-clients-by-id at the /clients endpoint using the client_id.
- Copy the JSON response body and identify which values need to be updated. Make changes to the values as appropriate.
- At this stage, remove tenant, name, and client_id from the response. Some of these fields cannot be changed, and including them in a JSON request to update the client will result in an error. Depending on the specific SSO Integration, following Step 6 will return a different error message. Change the JSON request body according to the errors to remove the unmodifiable fields from the body.
- Navigate to Update a Client: Patch client by ID
- Paste the client_id and the JSON request body in the appropriate text boxes.
- Send the request.
Retrieving the Client details at this stage should show the updated value.