Changing language in new universal login experience

Hi There,

I am using new universal login experience and I want to change the language from english to japanese so I am doing this

this.auth0Client$.subscribe((client: Auth0Client) => {
// Call method to log in
client.loginWithRedirect({
redirect_uri: window.location.origin + ‘/logincallback’,
appState: { target: redirectPath },
ui_locales: ‘ja’,
});
});
}

Now I am not able to pass the accept language in authorize endpoint. So can you tell me how can I pass it to the authorize endpoint as my default browser accept-language is en

Best Regards,
Auth0 Team

Hello, @ashish.sharma!

Have you configured your tenant Settings to allow the supported language?

You can read more about it here: https://auth0.com/docs/universal-login/universal-login-internationalization#setting-the-tenant-supported-languages

In the General tab on your Tenant Settings you will be able to select the languages you would like to allow.

Hope this helps

Thanks!

Yes I have set the languages in tenant setting and once I load the page it loads in japanese but after one or two second it is changed to english automatically. I am not sure why is this happening?

Hey there Ashish!

Can you share with me via private message the HAR file of the transaction. Record the flow when you change that language and it displays in JA but in a few secs change to ENG. I will inspect what is happening behind the scenes of the browser. Here’s how to do that:

1 Like

Thanks a lot for your help, Now it is working fine Also I want to hide sign up link from footer in new universal login exp. How can I do this?

1 Like

Perfect! Glad to hear that! Have you changed something else that it suddenly start working? As this thread is about adjusting language please open another topic for customising UL look, that will allow others to more easily find it in the future. Thank you!

1 Like

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.