Change Password template email not redirecting after password change

I know this question has been asked several times, but, it simply isn’t working. I am making a call to the Auth0 management API for a new user to allow them to set a password:


I have tried passing the clientId of the machine to machine application (that I am connected to), as well as the single page application clientId. I receive the email fine, and when I change the password it doesn’t redirect me to my home page.

I have the “Change Password” email template Redirect URL set:

and I have the Application Login URI set for the application I am using:

I am using the new universal login. Have basically exhausted all options on getting this to work, and it just doesn’t want to. Is there something else that needs to be set in the change password template itself?

Previously, I had code to send a CreatePasswordChangeTicket which worked, as I was able to prepend “?type=invite” to the password set URL, which seemed to be the key to allow the redirect to work. However, this method doesn’t allow you to use the change password template (which we want).

I have also looked at Why is password change/reset redirect not working? and confirmed I am doing all of those things (as mentioned above) but it just doesn’t want to redirect.


1 Like

I should add that I think maybe it has to do with the fact that I am using a Customize Password Reset Page - if I can somehow add functionality there to redirect, that would be ideal.