Certificat error

I have a error in my rules , we call my api :
Error: certificate has expired
at TLSSocket. (_tls_wrap.js:1116:38)
at emitNone (events.js:106:13)
at TLSSocket.emit (events.js:208:7)
at TLSSocket._finishInit (_tls_wrap.js:643:8)
at TLSWrap.ssl.onhandshakedone (_tls_wrap.js:473:38)
{ adapter: [Function: httpAdapter],
transformRequest: { ‘0’: [Function: transformRequest] },
transformResponse: { ‘0’: [Function: transformResponse] },
{ Accept: ‘application/json, text/plain, /’,
‘Content-Type’: ‘application/json’,
‘User-Agent’: ‘axios/0.15.2’,
‘Content-Length’: 132 },
timeout: 0,
xsrfCookieName: ‘XSRF-TOKEN’,
xsrfHeaderName: ‘X-XSRF-TOKEN’,
maxContentLength: -1,
validateStatus: [Function: validateStatus],

my certificat is valid until one month


Hey there @nseb!

Can you send me your tenant name via private message so we can investigate that? Thank you!

And also can you tell me if that still happens for you? When trying again do you still get this error?

Hello ,
I solved my problem by migrating my rules node 8 to 12. Despite everything, I don’t know why it didn’t work suddenly, an intermediate certificate in node8 which was expired?

Best Regards

1 Like

Glad to hear that! We’re investigating that, I’ll share the info with you once we have an update on that front.

The only information I managed to gather that there were some certificate issues around weekend the prevented some people from calling their APIs. The API is what needs to have the certificate updated, because it / they has / have an expired certificate in the chain. In some cases users were able to fix it themselves in some cases we did that.