Overview
The tenant administrator receives the following error when updating a tenant-based self-service subscription to a team-based subscription.
Unable to Upgrade Subscription
Applies To
- Subscription
- Upgrades
- Auth0 Teams
- Self-Service Subscriptions
Cause
When a tenant-based subscription is upgraded from the Manage Dashboard > Settings > Subscriptions, a new Auth0 Team is generated for the tenant, and the subscription becomes team-based and managed from the Team Dashboard. If the dashboard admin upgrading the subscription already created an Auth0 Team associated with other tenants, they will receive an error when trying to create the new team as a result of the upgrade because our platform restricts the users to create only one team per dashboard user.
Note: this restriction applies only to Team creation. The same dashboard user can be invited and belong to multiple teams.
Solution
To solve this, the affected user has two options:
- Have another tenant admin who does not already have an account/team perform the upgrade.
- Upgrade the subscription of the existing team account from the Team Dashboard > Settings > Subscription
After completing one of those steps, link the tenant to that team, as indicated in the Link Tenants with Auth0 Teams documentation.